We have restored the missing tasks. Our team is currently conducting a comprehensive audit to ensure data consistency across all systems. During this audit phase:
* All services are operating normally * No user action is required at this time
Posted Apr 01, 2025 - 15:59 EDT
Identified
We have identified the issue and are working to restore the missing tasks.
Posted Apr 01, 2025 - 14:43 EDT
Investigating
We are investigating an incident where a number of turnover jobs are missing tasks.
Posted Apr 01, 2025 - 13:54 EDT
This incident affected: Platform Engine, Web Portal, and Mobile App.