Some SuiteSpot Mobile Users on IOS Devices Expriencing a White Screen After Update

Incident Report for SuiteSpot

Resolved

We have just released version 2.5.1 of the SuiteSpot Mobile app to the app store. Installing this version recovers iOS devices that may be stuck on application startup. We encourage all iOS users to update to the new version.
Posted Apr 05, 2024 - 17:29 EDT

Monitoring

We have received reports from some users that the SuiteSpot Mobile app on their iOS devices is stuck on a white screen on startup following a recent update. We have determined that the issue is caused by the background update mode of the application and we have since disabled this mode as of 1PM EST. Any updates after 1PM EST, April 4, 2024 will not be affected by the issue.

If you are currently experiencing this problem, uninstalling and then reinstalling the mobile app will restore functionality. We are working on a new binary application release that is expected to restore functionality without requiring an uninstall for the affected users.
Posted Apr 04, 2024 - 15:29 EDT
This incident affected: Mobile App.