We have confirmed that the functionality and performance of the tasks and jobs screens have been restored.
Posted May 28, 2025 - 17:12 EDT
Update
The database index has been rebuilt. We have reverted the workaround to restore the performance of the jobs and tasks screens. We are continuing to monitor for any further issues.
Posted May 28, 2025 - 11:36 EDT
Monitoring
We have applied a workaround while the database index is rebuilding. The jobs and tasks screen are currently operational. We are closely monitoring the fix.
Posted May 28, 2025 - 11:27 EDT
Identified
We had identified an issue with one of the database index that is preventing some of the screens in the SuiteSpot desktop application from loading data. Our teams are currently rebuilding the index and expect the screens to be operational in 30 minutes.