System is not accessible

Incident Report for SuiteSpot

Resolved

The incident has been resolved. We are working internally to deploy further safeguards to prevent a re-occurence of this event.
Posted Nov 21, 2022 - 16:39 EST

Monitoring

Our cloud team has restored service. We are working to ensure the system is back to optimal capacity.
Posted Nov 21, 2022 - 16:34 EST

Identified

We have localized the issue to the database subsystem and are working with our cloud team to restore service.
Posted Nov 21, 2022 - 16:14 EST

Investigating

We are currently investigating an issue affecting access to the system.
Posted Nov 21, 2022 - 15:32 EST
This incident affected: Platform Engine, Web Portal, and Mobile App.