We have identified a group of changes in the latest release that were causing a slowdown. We have reverted the changes and are implementing mitigation mechanisms to prevent this happening in the future. All systems are currently operational.
Posted May 03, 2024 - 12:17 EDT
Update
We have restored nominal performance for the system. We continue to investigate to determine the root cause of the issue.
Posted May 01, 2024 - 10:31 EDT
Investigating
We are currently investigating slow response times on some of the hosts in the core infrastructure.
Posted May 01, 2024 - 09:49 EDT
This incident affected: Platform Engine, Web Portal, and Mobile App.