We have confirmed all our upstream providers for Engage and Contact has been fully restored, and our services are fully operational.
Posted Jun 12, 2025 - 18:17 EDT
Update
Our upstream providers for Contact has reported full operational restoration. Engage delivery SMS messages may still be delayed to Cingular Wireless (AT&T) in the U.S. We will continue to monitor closely.
Posted Jun 12, 2025 - 17:03 EDT
Update
We are starting to see recovery in both Contact & Engage. We are continuing to monitor closely.
Posted Jun 12, 2025 - 16:41 EDT
Update
We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 15:10 EDT
Monitoring
We are currently seeing outages of our upstream network providers for managing our Engage SMS and Contact AI agents.
We are actively monitoring the situation and will provide updates as soon as we have more information.